Coupler

Coupler is a desktop application for record linkage. It is currently under heavy development.

Java Setup

To use Coupler, you first need to make sure you have Java installed on your system. At the moment this is something you have to do yourself, unfortunately. In the future, Coupler will have an installer program that will be able to set up Java for you in case you don't have it.

Ubuntu Linux

Ubuntu has OpenJDK installed by default, which hasn't been tested for Coupler yet. Instead, you should use Sun's version of Java. You may already have that installed. To check, run java -version from a terminal. If you have Sun's version of java installed already, you'll see something like this:

java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02, mixed mode)

If this is what you see, you're ready!

If you see anything that says "OpenJDK", then you probably need to install Sun's version of Java. Follow the directions found here in order to do that: http://www.clickonf5.org/linux/how-install-sun-java-ubuntu-1004-lts/7777

Windows

First, check to see if you have Java installed already. Click this link to see: http://www.java.com/en/download/testjava.jsp.

If you see "Your Java is working", then you're good to go. Otherwise, you'll need to install or upgrade Java. Visit http://www.java.com and click the "Free Java Download" button. Then follow the directions.

Mac

You already have Java installed! smile

Installation and Usage

Once you have Java setup, there are two ways to use Coupler. The first and easiest way is to use Coupler's Launcher program. Visit this link and download the coupler-launcher jar file you find there: http://github.com/coupler/coupler-launcher/downloads.

Once downloaded, try double clicking the file. If you see the Coupler splash screen, then Coupler is running!

In Linux or Mac, if you don't see the Coupler splash screen, try running the jar file in a terminal like this:

java -jar coupler-launcher-xxxxxxx.jar

The "xxxxxxx" is tied to the launcher version. Substitute that with the version of the Coupler launcher file you downloaded.

Using Coupler's launcher will guarantee that you always have the latest version of Coupler, since it will update Coupler automatically each time you run it.

Advanced Installation

If you want, you can also install and run Coupler with an existing JRuby installation. On Mac or Linux, the easiest way to use JRuby is via RVM (ruby version manager). Coupler is packaged as a Ruby gem, so once you have JRuby setup, simply run: gem install coupler.

Once installed, run Coupler from your terminal with the command: coupler

The disadvantage of using Coupler this way is that you have to upgrade Coupler yourself when there is a new version. You do that by running: gem update coupler.

Contributing

If you are a developer and want to help out, please look at the [[http://github.com/coupler/coupler][source code]. If you want to test out Coupler or have some suggestions about features, feel free to contact [Richard Urbano] or [Jeremy Stephens]. Keep in mind that Coupler is still under heavy development.

Troubleshooting

If you have a problem running Coupler, or if you find bugs, contact [Jeremy Stephens] via e-mail. Alternatively, you can create a bug report on Github.

Links

Topic revision: r3 - 24 May 2011, JeremyStephens
 

This site is powered by FoswikiCopyright © 2013-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Vanderbilt Biostatistics Wiki? Send feedback