This problem resulted from trying to install rekall on 4/19/04. Some packages could not be installed correctly thus breaking apt-get until they could be corrected.

  • Here's a look at the initial problem:
biostat027:/home/beckca/Desktop/rekall# apt-get check
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libice-dev: Depends: libice6 (= 4.3.0-7) but it is not installed
  libsm-dev: Depends: libsm6 (= 4.3.0-7) but it is not installed
  libx11-dev: Depends: libx11-6 (= 4.3.0-7) but it is not installed
  libxext-dev: Depends: libxext6 (= 4.3.0-7) but it is not installed
  libxi-dev: Depends: libxi6 (= 4.3.0-7) but it is not installed
  libxmu-dev: Depends: libxmu6 (= 4.3.0-7) but it is not installed
  libxmuu-dev: Depends: libxmuu1 (= 4.3.0-7) but it is not installed
  libxp-dev: Depends: libxp6 (= 4.3.0-7) but it is not installed
  libxpm-dev: Depends: libxpm4 (= 4.3.0-7)
  libxrandr-dev: Depends: libxrandr2 (= 4.3.0-7) but it is not installed
  libxt-dev: Depends: libxt6 (= 4.3.0-7) but it is not installed
  libxtrap-dev: Depends: libxtrap6 (= 4.3.0-7) but it is not installed
  libxtst-dev: Depends: libxtst6 (= 4.3.0-7) but it is not installed
  libxv-dev: Depends: libxv1 (= 4.3.0-7) but it is not installed
E: Unmet dependencies. Try using -f.

  • I can look at any of these packages:
biostat027:/home/beckca/Desktop/rekall# dpkg -l | grep libice-dev
iU  libice-dev     4.3.0-7        Inter-Client Exchange library development fi
  • Notice that they are installed yet unconfigured (iU)

  • Let's try to configure them:
biostat027:/home/beckca/Desktop/rekall# dpkg --configure libice-dev
dpkg: dependency problems prevent configuration of libice-dev:
 libice-dev depends on libice6 (= 4.3.0-7); however:
  Package libice6 is not installed.
dpkg: error processing libice-dev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libice-dev
  • I need libice6 installed

  • I cannot install libice6 until the unmet dependencies are fixed!!!

  • Here's the output from apt-get -f install (this is a good idea to try first):
biostat027:/home/beckca/Desktop/rekall# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libice6 libsm6 libx11-6 libxext6 libxi6 libxmu6 libxmuu1 libxp6 libxpm4 libxrandr2
  libxt6 libxtrap6 libxtst6 libxv1
The following NEW packages will be installed:
  libice6 libsm6 libx11-6 libxext6 libxi6 libxmu6 libxmuu1 libxp6 libxpm4 libxrandr2
  libxt6 libxtrap6 libxtst6 libxv1
0 upgraded, 14 newly installed, 0 to remove and 577 not upgraded.
43 not fully installed or removed.
Need to get 0B/2661kB of archives.
After unpacking 5833kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 135042 files and directories currently installed.)
Unpacking libice6 (from .../libice6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libice6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libICE.so.6.3', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libsm6 (from .../libsm6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libsm6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libSM.so.6.0', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libx11-6 (from .../libx11-6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libx11-6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxext6 (from .../libxext6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxext6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXext.so.6.4', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxi6 (from .../libxi6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxi6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXi.so.6.0', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxt6 (from .../libxt6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxt6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXt.so.6.0', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxmu6 (from .../libxmu6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxmu6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXmu.so.6.2', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxmuu1 (from .../libxmuu1_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxmuu1_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXmuu.so.1.0', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxp6 (from .../libxp6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxp6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXp.so.6.2', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxpm4 (from .../libxpm4_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxpm4_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXpm.so.4.11', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxrandr2 (from .../libxrandr2_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxrandr2_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXrandr.so.2.0', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxtrap6 (from .../libxtrap6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxtrap6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXTrap.so.6.4', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxtst6 (from .../libxtst6_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxtst6_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXtst.so.6.1', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libxv1 (from .../libxv1_4.3.0-7_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libxv1_4.3.0-7_i386.deb (--unpack):
 trying to overwrite `/usr/X11R6/lib/libXv.so.1.0', which is also in package xlibs
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libice6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libsm6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libx11-6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxext6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxi6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxt6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxmu6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxmuu1_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxp6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxpm4_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxrandr2_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxtrap6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxtst6_4.3.0-7_i386.deb
 /var/cache/apt/archives/libxv1_4.3.0-7_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • xlibs is foiling my plans and won't let me overwrite what's there


Solution
  • Do this for every package to overwrite what is currently there
cd /var/cache/apt/archives/
dpkg -i --force-overwrite <package>_4.3.0-7_i386.deb

  • Only one error resulted when I did this:
dpkg: dependency problems prevent configuration of libxrandr2:
 libxrandr2 depends on libxrender1; however:
  Package libxrender1 is not configured yet.
dpkg: error processing libxrandr2 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libxrandr2

  • Thus try dpkg --configure libxrender1 then dpkg -i... again

  • This corrected all dependency problems

-- ColeBeck - 19 Apr 2004
Topic revision: r2 - 03 Dec 2007, ColeBeck
 

This site is powered by FoswikiCopyright © 2013-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Vanderbilt Biostatistics Wiki? Send feedback