Frequently Asked Questions (FAQ)

Related Topics

How does a new employee get information about getting started in Biostatistics?

Our wiki has a "Getting Started at Vanderbilt Biostatistics" topic. This topic is a collection of what one needs to know to get started at Biostatistics. The focus mainly on Information Technology and related subjects. Vanderbilt Information Technology has a Getting Started: Get up and running at Vanderbilt page that has some helpful information.

Where can I get information about cyber security?

See the Data Security section of Getting Started at Vanderbilt Biostatistics topic.

How do I share data with a statistician

Recovering email erroneously marked as spam

  • Open Firefox (other browsers will probably work but I tested with Firefox on Linux)
  • Navigate to https://email.mc.vanderbilt.edu
  • Open the Spam Notification email
  • Click “Release to Inbox” for the appropriate message
  • Wait a little bit and a web page should pop-up containing the message “Spam message was released from quarantine”
  • The message (with today’s date) will appear in your Inbox

Where can I find information about Vanderbilt's high performance compute cluster (ACCRE)?

Where can I get information about the department's computer server resources?

Where can I find information about logos and templates?

BiostatLogo

How do I get a Shiny app hosted?

How do I deploy a Shiny app?

We have set up a Shiny server on our statcomp2 server. See for example http://statcomp2.vanderbilt.edu:37212/VisualPruner/

To install your shiny app on the statcomp2 server, do the following:

  1. Develop your shiny app and get it working on your workstation.
  2. Ask me for an account on statcomp2.vanderbilt.edu if you don’t already have one.
  3. Log on to your statcomp2 account and make a new sub-directory called /home/vunetid/ShinyApps/ (where “vunetid” is your VUnetID)
  4. Make an appropriately named directory in /home/vunetid/ShinyApps/. For example, if your app is called "MyApp1" then make a directory /home/vunetid/ShinyApps/MyApp1.
  5. Copy your Shiny application to this new directory.
  6. Let me know when you are done. I have to add a link. After that your application will be live.

Browse files on a server or network share

Automount windows share in Ubuntu

See http://stackoverflow.com/questions/33566227/automount-windows-share-in-ubuntu-14-04-lts

Lets say there is a share being served from a Windows computer that we need to use regularly. We'd like to mount that share on our Linux computer.

In the notes below
  • $SERVER is the name of the server
  • $SHARE is the the name of the share to be mounted
  • $VUNETID is the user's VUnet ID
  • $EPASSWORD is the user's ePassword
  • $MOUNTPOINT is a directory serving as the local mount point. This is typically named the same as the share but can be any directory that the user can write to. This directory must be empty.

Create a mount point. This is just a directory the share is mounted and where it can be accessed on the Linux computer.
mkdir /home/$VUNETID/$MOUNTPOINT

Add this line at the end of the /etc/fstab file
//$SERVER/$SHARE /home/$VUNETID/$MOUNTPOINT cifs credentials=/home/$VUNETID/.smbcredentials,uid=$VUNETID,domain=vanderbilt,iocharset=utf8,_netdev,sec=ntlm 0 0

Create a file called /home/$VUNETID/.smbcredentials. Put these lines in that file.
username=$VUNETID 
password=$EPASSWORD
domain=vanderbilt

Protect .smbcredentials (it contains a password!).
chmod 600 /home/$VUNETID/.smbcredentials

Mount the share
sudo mount -a

How to operate the Garden Room audiovisual system

How do I operate the projectors in the 2525 conference room and classroom?

To turn the system on, press the VGA or HDMI button as appropriate.
  • Use the HDMI button for the conference room Linux computer, Apple TV device, or anything else connected to the podium switch box. This could be a speaker provided laptop.
  • Use the VGA button for anything connected to the black extension cable (most likely a speaker provided laptop).

It will take a minute or two for the system to lower the screen, turn on the projector, and warm up. Please press the button only once.

To turn the system off, press the DISPLAY OFF button. It will take a minute or so for the system to raise the screen and shut down. The DISPLAY ON and DISPLAY OFF lights will flash during the shutdown process. Please press the button only once. Please turn the system off when you are finished. Contact Dale or one of the IT Team if you have problems.

There is no need to press any of the other buttons.

projector control panel

What are the names of the various department Exchange calendars?

Calendar Exchange Name Notes Email address
Department event calendar vmcbiosta2   biostatistics.calendar@vanderbilt.edu
2525 West End room 11129 mscbiostat small conference room biostat.rm11129@vanderbilt.edu
2525 West End room 11105 mscbiosta1 big conference room biostat.rm11105@vanderbilt.edu
2525 West End room 11139 mscbiosta2 class room biostat.rm11139@vanderbilt.edu
MCN D2221 vmcbiosta1 MCN conference room biostat.conferenceroom@vanderbilt.edu

How do I work with our wireless network environment?

See Wireless Access for VUMC Employees and VUMC Wireless Guest and Patient Access for the official information about wireless networking at VUMC. It pretty much works as advertised.

What are the network addresses (hostnames) for the department's printers?

If you want to install your own printer drivers you will need to know the network address of the printer you wish to install. Most installation tools will attempt to find all the printers on the network and let you pick one. This rarely works because there are so many printers around and sometimes the printer you want is not found. It is better to specify explicitly the printer in question. All installation processes I have seen provide an option to specify the printer web address directly.

The type of printer can be also be found there. You'll need to know that when installing the printer. You'll also need to know the printer type if you have to download a driver from the manufacturer.

The procedure for installing these printers on the Linux computers is on the workstation setup wiki page.

How to install printers...

...on the Linux workstations

See the workstation printer set up instructions

...on Windows 7 computers

See Windows 7 instructions for installing HP M651 printers (pdf)

...on Macintosh computers

See Macintosh instructions for installing HP M651 printers (pdf)

Notes on Using Exchange 2010

Here are some links to information on using Exchange 2010 calendaring. Please send questions and comments to biostat-it@list.vanderbilt.edu and we will update as needed.

There are some functions available on the Outlook Windows Client that are not available in the Outlook Web App (OWA). There is a laptop set up and available to anyone who does not have the Outlook Windows client and needs one of the features that is missing in OWA. Here are links to some web sites that discuss the differences.

Using the Pidgin Instant Messaging Client with Lync

Using the Pidgin Instant Messaging Client with Lync

Letterhead templates and images

See Audrey Carvajal if you need letterhead templates in Word, PDF, or other formats.

How to dual-boot Ubuntu 12.04 and Windows 7

See http://www.linuxbsdos.com/2012/05/17/how-to-dual-boot-ubuntu-12-04-and-windows-7/2/ for step by step instructions. The article mentions EasyBCD, a free program by NeoSmart Technologies, that can be helpful if the boot menu needs to be fixed. Note that the article recommends a Linux partitioning scheme that is different from what we use in Biostatistics. See Setup for Ubuntu 11.10 (and up) for our Linux setup instructions.

How to set up a screensaver so that the desktop locks after a certain amount of time?

The procedure varies depending on which window manager you are using. If you don't know, ask one of the IT team.

If you are using KDE (usually has the toolbar on the bottom) follow these steps:
  • click the Start button (the "K" button) on the lower left of the desktop.
  • click on "System Settings"
  • click on Desktop
  • Click on the "Screen Saver" icon.
  • Make sure "Start automatically" is checked.
  • Set the amount of time before the screensave starts.
  • Make sure "Require Password to stop" is checked.
  • Set the amount of time until a password is required to stop the sreensaver.
  • Click "Apply" to save settings.
  • Exit the System Settings tool.

If you are using Unity (usually has the toolbar on the left side) follow these steps:
  • run the System Settings application. To do so..
    • ...click on the System Settings icon on the toolbar (if it is there) or
    • ...click on the start button (upper right of desktop) and select System Settings
  • click on the "Screen" icon
  • Set "Turn off after" to the desired interval
  • make sure the Lock is ON
  • set "Lock screen after" to desired interval
  • Exit the System Settings tool

On either system, you can lock immediately by typing Ctrl+Alt+L. There is also a Lock Screen option in the "Leave" or "Logout" dialog on both systems.

How do I "de-identify" a data set to remove private information?

What are the LDAP directory settings to use with Thunderbird email client?

  • Edit menu ... Accounting Settings
  • Select the Composition & Addressing item
  • Click on the Edit Directories... button
  • Define the directory server like this:
    • Name: VUdirectory
    • Hostname: vudirectory.vanderbilt.edu
    • Base DN: dc=vanderbilt, dc=edu
    • Port number: 389
    • Bind DN: blank

Use secure connection (SSL) can be checked or unchecked (I like checked)

How do I send sensitive data electronically

See Vanderbilt's Secure File Transfer web topic. See also The Data-Hippo Secure Data Transfer Application.

Where are "How To" Pages on the Biostatistics Wiki?

How To Pages

What are some Stata learning resources that you recommend?

Each of these will have some information that is specific to the originating institution.

From Princeton
http://www.princeton.edu/~otorres/Stata/
http://dss.princeton.edu/training/StataTutorial.pdf

UCLA Academic Technology Services
http://www.ats.ucla.edu/stat/stata/
http://www.ats.ucla.edu/stat/stata/sk/default.htm

Economic and Social Data Service, UK
http://www.esds.ac.uk/government/docs/documents/StartingStata9.pdf

Institute of Economic Education, WWU Münster
http://www.wiwi.uni-muenster.de/ioeb/Downloads/Forschen/Pfaff/Introduction_to_Stata_with_50+_Basic_Commands.pdf

How do I configure an instant message client to work with Biostatistic's jabber server?

PidginSetup

Where can I find how to configure my email client to work with Vanderbilt email?

See http://it.vanderbilt.edu/services/messaging/email/ and click on the "Client Configurations" link.

SmartBoard information

A SmartBoard device is installed in Biostatistics conference room in Medical Center North. There are a number of good online tutorials for the SmartBoard at http://smarttech.com/trainingcenter/material.asp.

The SMART Notebook software can be downloaded from http://www2.smarttech.com/st/en-US/Support/SBS/. Having a local installation of the SMART Notebook software can be useful for editing and otherwise cleaning up notebooks captured in the conference room.

How do I test whether Java is working on my computer?

Try this java test:

http://java.com/en/download/help/testvm.xml

If that doesn't work and you are using Firefox, make sure you have sun-java6-plugin installed. If not, install it and restart Firefox.

Where can I get some help with R?

See Frank's R and S-Plus Packages, Functions, and Documentation. Of interest to new R users is Terri Scott's "An Introduction to the Fundamentals & Functionality of the R Programming Language" and other lecture notes that can be found on her page. Also of interest to R users coming from SAS or SPSS is R for SAS & SPSS Users by Robert Muenchen.

Where can I find "how to" help?

There are a lot of useful how to pages on our site. See How To Pages on the Biostatistics Wiki

Where can I get some programming tips?

"I am a statistician, not a programmer." How often have you heard this? See Programming Tips For Statisticians for programming hint and tips.

Introduction to Linux

The ACCRE web site (http://www.accre.vanderbilt.edu/) has a nice introduction to Linux formatted as a PDF file. See it at http://www.accre.vanderbilt.edu/docs/IntroductionToUnix.pdf. There are a few details that are specific to ACCRE, but for the most part it is appropriate for our environment as well.

SAS can be a little strange under Linux. Where can I find help on SAS for Linux?

See the SAS for Linux topic.

How do I enable the Jump Auto Completion feature of the Biostatistics web site?

By default, the Jump Auto Completion feature is not enabled if you are not connected to the Vanderbilt network. The instructions on the Topic Jump Auto Completion page.

To which Vanderbilt email lists am I subscribed?

You might be subscribed to one or more Vanderbilt email lists because of your job description or duties (for example, IT staff are on the biostat-it email list). You can get a list of all the lists to which you are subscribed at https://list.vanderbilt.edu. Click on the Browse button near the top of the page, enter your vunetid and epassword, select the "Subscribed" radio button, and click Go. The process is a little slow, but you will eventually be given a list of all your subscribed email lists.

How do I run my R program as a batch job?

The problem: If one runs a program as an interactive job (i.e. connected with a terminal session) then the job will be terminated if the interactive session gets disconnected. The interactive session will most certainly get disconnected if it sits idle without any keyboard input or video output for a while. This is a feature of the Vanderbilt network that we cannot change.

The best way to execute long running jobs is to run them as batch jobs. When running as a batch job, the process is not dependent on the existence of a terminal session. One can launch the job and log out and it will continue to run.

Say you have a script file (e.g. runr.sh) that runs your R program:

R CMD BATCH --vanilla my_long_job.R my_long_job.Rout

This will execute the R commands that are stored in the file my_long_job.R and write the output to a file my_long_job.Rout. Use of the option --vanilla is just an example. A number of options can be specified as desired. You can google "R CMD BATCH" for more information about how this works.

One of the following techniques will allow you to run the job without the job being dependent on a terminal session:

1. Use the "nohup" command to run the script, e.g.:

$ nohup sh ./runr.sh &

2. use the "at" command to submit the script to a batch queue, e.g.:
$ at now
at> /path/to/runr.sh
at> ctrl-d
$

If you plan to use the second method, then make sure that the script file (e.g. runr.sh) is set as executable (chmod u+x runr.sh).

Be sure to read the man pages for nohup (man nohup) and at (man at) for further details.

How do I add fonts to a Wine installation?

One important thing to do is to install the msttcorefonts package

$ sudo apt-get install msttcorefonts

This package will give you the Arial, Comic Sans, Courier New, Georgia, Impact, Times New Roman, Trebuchet, Verdana, and Webdings TrueType fonts.

Other TrueType fonts and be installed by copying the appropriate .ttf file into the Wine installation fonts directory. For example:

$ copy /my_downloaded_fonts/symbol.ttf /home/vunetid/.wine/drive_c/fonts

How do I make the wiki edit box bigger?

The edit box used to create and edit wiki pages is pretty small and the font is too little. How can I make these bigger?

To make the edit box bigger, add two lines like these to your personal page:
   * Set EDITBOXWIDTH = 70
   * Set EDITBOXHEIGHT = 25
The 70 and 25 can be changed to suit your tastes, but these values seem to work pretty well.

In the Firefox web browser, the font size in the twiki edit box can be changed by going to the Edit menu, clicking on Preferences, then clicking on the Content item. Click on the Advanced button in the Font & Colors section. In the Fonts dialog that appears change the Monospace font size to something a little larger than the default (16 is a pretty good size).

How do I get the combination of R, Sweave, and MikTeX to work on Windows?

There is a problem with how the MikTeX Latex interpreter handles spaces in file path names when it attempts to find and load style (.sty) files. In the .tex file produced by Sweave there will be a line that looks something like this:

\usepackage{c:/progra~1/R/R-23~1.1/share/texmf/Sweave}

This line is intended to tell the Latex package to load the style package "Sweave" where it can find the style file Sweave.sty. This is the line that causes the problem. The solution is to put a copy of the Sweave.sty file in a directory that is on the Latex search path. A good choice is to create the directory c:\Program Files\MikTeX 2.5\tex\latex\sweave and put Sweave.sty there. After creating the sweave directory and placing the Sweave.sty file there we need to let MikTeX know that it has a new style file. This is done by updating the MikTeX file name database (start...MikTeX 2.5...Settings and then click on the "Refresh FNDB" button).

We can then change the offending line in the .tex file to:

\usepackage{Sweave}

Latex will now have no problem finding the file since it does not have to figure out the path.

Wiki topic naming advice

Over time several Wiki users have created topics for specific reasons but have assigned generic names to these topics (e.g. JournalClubICUD, MyLearning). There is nothing wrong with this but in some circumstances it can prevent a later user from creating a topic that needs to be fully generic. This is more important now that you can link to a topic with a short name you can publish, such as biostat.mc.vanderbilt.edu/MyTopic . It would be best if we reserved generic names for topics that are for general use that spans multiple groups. You might consider using names such as ProjxJournalClub for Project X's Journal Club.

Thanks for your consideration.

How do I Install Acrobat Reader?

Later versions of Ubuntu have a package available that makes installing Acrobat Reader easy. You can use the command line...

sudo apt-get install acroread

...or use one of the fancier software management tools like KPackageKit. If you want or need the very latest version of Acrobat Reader you can download it from http://get.adobe.com/reader/ and follow the instructions.

Note that in most cases, Acrobat Reader will not be necessary. The universal document reader Okular is now included in the current release of Ubuntu and it does a good job rendering most pdf formatted documents.

Backups

Backup are being performed for the following locations each night:

  • /home/vunetid on your personal linux workstation
  • /home/vunetid on biostat.mc.vanderbilt.edu
  • other appropriate directories on data.vanderbilt.edu and statcomp2.vanderbilt.edu.

Excluding Files from Backups

If you have a external mount point in your home directory you should not have this backed up. To exclude a dir or file from being backed up place a rsync exclude rule in the file .backup-exclude
  • Example: excluding ~/mnt. Run the following command
    echo "- /mnt/" >> ~/.backup-exclude
    

Restoring Deleted Files

If you have deleted a file or collection of files and would like to restore them, please email biostat-it@list.vanderbilt.edu with the following information:

The names, locations, and dates of the files that you would like to be restored. The location will include the hostname and the directory where the file resided.

As an example, If I accidentally deleted /home/vunetid/Desktop/FinalProposal.tex from my linux workstation biostat028 on October 27, 2004, I can ask to retrieve that file as it looked on October 26, 2004 or earlier. My email to biostat-it will look like this:

    To: biostat-it@list.vanderbilt.edu
    Date: October 27, 2004
    Subject: RESTORE request

    Please restore the following file as of October 26, 2004:

    biostat028:/home/vunetid/Desktop/FinalProposal.tex

    and place it in the folder:

    biostat028: /home/vunetid/Desktop/RESTORE

    Thanks

The turn-around time on restoring files will be anywhere from 2 to 5 days. Also, If you have any questions about backups don't hesitate to email us at biostat-it@list.vanderbilt.edu.

How do I recover a VMWare session in a locked X windows instance?

  • This will not work if VMWare player is installed.
  1. Log into affected computer.
  2. run this command to list out running virtual machines
    vmrun list
    
  3. select the correct virtual machine and suspend it using the following command.
    vmrun suspend <path to .vmx file (virtual machine)>
    
  4. the virtual machine has now been suspended. The computer may now be rebooted with out loss of data in the virtual machine.

Remote Access

  • Tools that can be used on a Windows system to access your office Linux workstation or one of the Biostatistics servers:

  • Tools that can be used on a Linux system to access your Linux workstation or one of the servers:
    • ssh
    • scp
    • Konqueror and the "fish" protocol; The FISH (FIles over SsH) protocol allows you to access another computer's files using an SSH shell account and standard utilities on the remote side. It allows secure browsing of the remote machine's file structure as if it is locally mounted. In this screenshot of fish in action, the local file system is displayed in the left panel and the remote files are in the right panel. Files can be copied from computer to computer by dragging between the panels.

Connecting to Linux desktop from a remote location (FreeNX)

Notes from Jeremy's "Working Remotely" seminar

On the Linux side (the "server") we have had some success using FreeNX.

"NX is a technology for remote display. It provides near local speed application responsiveness over high latency, low bandwidth links. The core libraries for NX are provided by NoMachine under the GPL. FreeNX is a GPL implementation of the NX Server and NX Client Components."

"FreeNX is a system that allows you to access your desktop from another machine over the internet. You can use this to login graphically to your desktop from a remote location. One example of its use would be to have a FreeNX server set up on your office computer, and graphically logging in to the office computer from your home computer, using a FreeNX client."

The main FreeNX website is http://freenx.berlios.de/.

To install on Kubuntu Linux, see the instructions at https://help.ubuntu.com/community/FreeNX. Look for "Installing the FreeNX server on Ubuntu Karmic (9.10)".

On the Windows side, use the NX client for Windows from the NoMachines web site (http://www.nomachine.com/select-package-client.php). It seems to work well.

The nice thing about FreeNX is that it does not require that one be running Vanderbilt's VPN software to connect. The client evidently uses port 22 (ssh) to establish the conversation with the FreeNX server. Any other traffic is moved on connections originated on the server which is inside the firewall and not blocked in any way.

How do I make a connection to my workstation from off campus?

It is Vanderbilt network policy to issue "non-routable" IP address to our desktop and laptop computers. That means that these systems are not accessible from outside the Vanderbilt network unless one first connects using Virtual Private Network (VPN) software. Details and instructions for making a connection using Vanderbilt's VPN system are at...

http://it.vanderbilt.edu/security/secure-communications/remote-access/

This software should work for Linux, Macintosh, and Windows systems being used to remotely access Vanderbilt services and systems.

How do I get rid of White gaps between colors when printing.

Linux Questions

LaTex Links and Notes

  • LaTex cheat sheet
  • Commands to invoke LaTex and view or print the output:
        Linux
        $ latex test.tex   # invokes LaTex, processes test.tex, and writes test.dvi
        $ kdvi test.dvi    # opens test.dvi for viewing and printing
    
        Windows (MiKTex)
        > latex test.tex
        > yap test.tex
        

Emacs and Xemacs Questions

Copying to/pasting from emacs with other applications

  • Behaviour when pasting from emacs to another application can be unreliable. This can be helped by editing the emacs configuration file. Read this for more information.

Using the xemacs Package Manager

  • You can install ESS, AucTeX, RefTeX, and other packages using Tools...Packages but you have to do this as the superuser. First put the following commands in /root/.xemacs/init.el:
  (setq efs-generate-anonymous-password "yourID@vanderbilt.edu")
  (setq package-get-require-signed-base-updates nil)

Open Office Questions

Finding Help and Tutorials

Printing column headers on each page

  1. Format->Print Ranges->Edit
  2. Under Rows to repeat, select user defined and enter a range of rows ($1 would print the first row)
  3. Click OK

Printing Advice for Calc

Creating OpenOffice leaderheads

Print Arial font from OpenOffice

  • For some reason Arial printing does not work well in OO. For now, just Edit->Select All, and change the font type to Times.
  • We need a better solution for this problem.

Firefox browser and Thunderbird email client Questions

Thunderbird saves my attachments as read-only files. How do I stop that?

To make Thunderbird stop saving attachments as read only, do the following:
  • Edit ... Preferences ... Advanced ... Config Editor ...
  • Click "I'll be careful"
  • Search for deleteTempFileOnExit
  • Assuming you don't find it, right click in the large window showing all the parameter settings and then choose "New" ... "Boolean", add "browser.helperApps.deleteTempFileOnExit" as name and choose "False" as value.

Adapted from http://getsatisfaction.com/mozilla_messaging/topics/how_do_i_prevent_thunderbird_opening_all_attachments_as_read_only

How to turn on typeahead find in Firefox?

In a recent version of the Firefox browser (1.0-4), the typeahead find feature is not turned on by default and there is no GUI way to change that default. According to the Firefox 1.0 Release Notes, "The Configuration Console (accessed by entering "about:config" in the Location bar and pressing Enter) gives advanced/experienced users direct control over Firefox's preferences. This system is for use by people who know what they are doing only, by changing a value incorrectly you may damage or destroy your Firefox installation!"
  1. Enter about:config in the Location Bar to display the list of user preferences
  2. find the preference item "accessibility.typeaheadfind"
  3. right click on this item to open its context menu
  4. click on Toggle to change the preference status

How to add the Vanderbilt search engine as plugin for Mozilla Firefox (the search engines are located in the top right corner)

The information for these search engines is stored in /usr/lib/mozilla-firefox/searchplugins. You must create one file that specifies the search criteria (a src file) and one file that contains the image (a 16x16 pixel png or gif). Download vanderbilt.src and vanderbilt.png into the searchplugins folder and restart Firefox (if open).
Other searchplugins available

How do I install some language for web browsing in Firefox?

  • This requires root access
  1. Download the true type fonts for that language. The filename should end in .ttf.
  2. Create a directory for the fonts in /usr/share/fonts/truetype
    mkdir languagename
  3. Change to the new directory
  4. Move the fonts to the new directory
    mv /path/to/downloaded/fonts/*.ttf .
  5. Run mkfontdir
  6. Run fc-cache
  • If you want Chinese, you can download them by running:
scp biostat.mc.vanderbilt.edu:/usr/share/fonts/truetype/chinese/*.ttf .

How do I have firefox open a mail browser other then evolution

  1. Open gconf K => System => Configuration Editor
  2. In gconf Click on the arrow next to desktop
  3. Click on the arrow next to gnome
  4. Click on the arrow next to url-handelers
  5. Click on the folder named mailto
  6. Change key command to mozilla-thunderbird %s

How do I tell Thunderbird what programs to use to handle various attachments?

  • See Actions for attachment file types
  • For example, say you'd like acroread to be used for files with the .pdf extension:
    • Find out where acroread is located on your computer (whereis acroread)
    • If Thunderbird is already causing some other helper program to handle .pdf files, then go to the Edit menu and select Preferences. In the Thunderbird Preferences box, click on the View & Edit Actions... button. Click on the Change Action... button and make the appropriate changes.
    • If Thunderbird does not already have some helper program assigned to .pdf files, then the program will open a window where you can make the appropriate selection.

How do I set up Thunderbird to work well with the Vanderbilt Exchange server?

Set the mailto behavior in Firefox

KDE comes with Konqueror and Kmail set as the default web browser and email client. However, we prefer Firefox and Thunderbird. To change them to become the default programs, open KControl, open KDE Components, and click on Default Applications. Change the Email Client to thunderbird. Then open Web Browser, change the option to open http and https URLs to firefox, and hit Apply. Now, every time you click on a mailto:, http://, or https:// link, Thunderbird or Firefox will open.

Get Thunderbird to run Firefox when a link is clicked in an email message

(This applies to Kubuntu with Thunderbird 2 and Firefox 3.0. Should work for earlier versions, too.)

Open the config editor from within Thunderbird at Edit->Preferences->Advanced->General tab and then click the "Config Editor" button. In the Config Editor:
  • right click somewhere in the lower part, select New from the menu that pops up, and click on the String item
  • A box will pop up and ask you to "Enter the Preference name". Enter "network.protocol-handler.app.http" (without the quotes) in the box and click OK.
  • Another box will pop up where you enter the string. Enter "/usr/bin/firefox" (without the quotes). Click OK
  • Restart Thunderbird. That should do it.

How to install J2SE Runtime Environment (JRE)?

This answer is seriously out of date. I think that installing sun-java6-jre and sun-java6-plugin packages will get it done (sudo apt-get install sun-java6-jre sun-java6-plugin). A good answer to this and some Firefox plun-in installation questions can be found in the Unofficial Ubuntu 4.10 Starter Guide (see the Add-On Applications section). Ubuntu is a Debian based Linux distribution.

Migrating from Windows to Linux

IBM has published a "Redbook" aimed at assisting those interested in migrating desktop PCs to Linux. Linux Client Migration Cookbook: A Practical Planning and Implementation Guide for Migrating to Desktop Linux provides in-depth detail on the technical and organizational challenges and includes methods for planning and implementation, according to the book's cover. The 260-page book is available for free download as a PDF file.

Why does Linux use such funny naming schemes?

This article may not give you any great answers, but it does provide a list of Linux substitutes to Windows applications.

Accessing Win4Lin from a Linux computer

The Win4Lin server has been retired.

When I list my printers, I see devices I don't recognize. How do I keep CUPS from browsing?

(This needs to be done as root) There is a file /etc/cups/cupsd.conf where all kinds of CUPS settings can be made. Open this file in an editor and find the section that begins with
########
######## Browsing Options
########

Change the line #Browsing On to Browsing Off and restart CUPS (/etc/init.d/cupsys restart).

In Kubuntu see the file /etc/cups/cups.d/browse.conf. By default, browsing is off in Kubuntu.

Konqueror and pdf files

When I click on a link that points to a pdf file, I want Konqueror to use acroread to display the document. We assume that acroread is correctly installed.
  • click on the Settings menu and then the "Configure Konqueror..." item
  • Make sure the General tab has focus
  • click on the File Associations item in the left menu
  • expand the "application" group in the Known Types box and click on the the pdf type
  • in the "Application Preference Order" section, click on Add and enter the full path to the acroread application
  • click apply
  • click on the Embedding tab
  • for the "Left Click Action", select the "Use settings for 'application' group" item
  • click OK and you are done.

Firefox and pdf files

When I click on a link that points to a pdf file, I want Firefox to use acroread to display the document. We assume that acroread is correctly installed.
  • click on the link to the pdf file
  • the opening whatever.pdf box will be displayed
  • in the "What shoud Firefox do with this file?" section, click on the down arrow beside the "Open with" box
  • select "Other..."
  • type in the full path for acroread in the "File name:" box and click the Open button
  • Choose (or not) the "Do this automatically for files like this from now on" check box.
  • click OK
The configuration file that is changed by all of this is /home/vunetid/.mozilla/firefox/.default/mimeTypes.rdf.

Opening links in Firefox from Thunderbird

When I click on a link in Thunderbird, I want that page to open up in Firefox.
  1. Open gconf K => System => Configuration Editor (alternatively, from the command line, type gconf-editor)
  2. In gconf Click on the arrow next to desktop
  3. Click on the arrow next to gnome
  4. Click on the arrow next to url-handelers
  5. Click on the folder named http
  6. Change key command to mozilla-firefox %s
  7. Repeat the last step for the https folder

How do I install RealPlayer on my computer?

  • Go to http://www.real.com/ and, if necessary, click on the "Linux / Unix Player" link at the bottom of the page
  • Follow the instructions. They actually work.
  • To make realplay the konqueror default do the following:
    • go to Control Center and expand the KDE Components category
    • click on File Association
    • expand the Audio item in the Known Types box
    • click on the vnd.rn-realaudio item and move RealPlayer 10 to the top of the Application Preference Order
    • click on the x-pn-realaudio item and move RealPlayer 10 to the top of the Application Preference Order
    • click on Apply to apply the changes and exit Control Center
    • you might need to restart konqueror

How Do I get my usb flash drive to be mounted automatically?

The linux 2.6.12 kernel, and usb is required to for this solution to work.
  • Download the script usbmount.sh.
  • As root run
    # bash usbmount.sh
    
  • Add your self to the usb group.
  • In kde go to the desktop. Plug in your usb flash drive. You should see a new icon appear on your desktop with the name of you usb drive. Open the new icon. If you can see your files from you usb drive, it works and you're are done.

How should I organize my directories?

BASH questions

How do I prevent BASH from showing duplicate commands in my command history?

  • add the line to .bashrc: export HISTCONTROL=ignoreboth
Topic attachments
I Attachment Action Size Date Who Comment
1.jpgjpg 1.jpg manage 55.2 K 23 May 2011 - 15:13 DalePlummer  
2.jpgjpg 2.jpg manage 33.6 K 23 May 2011 - 15:12 DalePlummer  
HP_M651_Windows_Install.docxdocx HP_M651_Windows_Install.docx manage 737.6 K 16 Jul 2015 - 09:31 DalePlummer  
HP_M651_Windows_Install.pdfpdf HP_M651_Windows_Install.pdf manage 442.4 K 16 Jul 2015 - 09:31 DalePlummer  
How_to_Install_a_Printer.pdfpdf How_to_Install_a_Printer.pdf manage 431.4 K 13 Jul 2015 - 15:01 DalePlummer  
Letterhead2012-bottom.pngpng Letterhead2012-bottom.png manage 13.0 K 26 Nov 2012 - 10:26 DalePlummer letter head bottom portion in png format
Letterhead2012-top.pngpng Letterhead2012-top.png manage 32.0 K 26 Nov 2012 - 10:25 DalePlummer letter head top portion in png format
Letterhead2012.docdoc Letterhead2012.doc manage 92.5 K 26 Nov 2012 - 10:24 DalePlummer letter head in microsoft word format
Letterhead2012.odtodt Letterhead2012.odt manage 81.9 K 26 Nov 2012 - 11:37 DalePlummer letter head in odf document format
Letterhead2012.pdfpdf Letterhead2012.pdf manage 95.3 K 26 Nov 2012 - 10:25 DalePlummer letter head in pdf format
Letterhead2012.pngpng Letterhead2012.png manage 69.6 K 26 Nov 2012 - 10:25 DalePlummer letter head in png format
Letterhead2014.docdoc Letterhead2014.doc manage 92.5 K 24 Mar 2014 - 10:34 DalePlummer  
Letterhead2014.odtodt Letterhead2014.odt manage 45.6 K 24 Mar 2014 - 10:40 DalePlummer  
Letterhead2014.pdfpdf Letterhead2014.pdf manage 34.0 K 24 Mar 2014 - 10:34 DalePlummer  
Letterhead2014.pngpng Letterhead2014.png manage 29.9 K 24 Mar 2014 - 10:47 DalePlummer  
garden_room_av.pdfpdf garden_room_av.pdf manage 101.9 K 24 Sep 2015 - 14:57 DalePlummer  
mac_xerox_printer_installation_1.pdfpdf mac_xerox_printer_installation_1.pdf manage 3585.0 K 16 Nov 2012 - 11:50 DalePlummer  
photo.pngpng photo.png manage 1045.3 K 27 Feb 2014 - 15:34 DalePlummer  
Topic revision: r101 - 21 Aug 2017, DalePlummer
 

This site is powered by FoswikiCopyright © 2013 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Vanderbilt Biostatistics Wiki? Send feedback